FANDOM


  • Do you recall this discussion? I am wondering when that change to @import was reverted because it doesn't seem to be working anymore. I tried asking the general community (here) but everyone else are denying that such a change was ever made in the first place. I could swear the change did happen but, since I don't know the back end as well as you and KockaAdmiralac, that discussion is the only thing I have to make my case.

      Loading editor
    • according to this message, i was wrong somewhere. i can't recall what exactly it was, but some mistake definetely had place.

        Loading editor
    • Yes, I saw that when re-reading the entire thread. However, in it, you clearly specify personal CSS. That would seem to indicate that you were not wrong about site CSS. I don't know. Maybe I am going crazy or something.

        Loading editor
    • yes, it was about personal css only.

      now, i did recall the mistake: when i was testing imports, i have checked joined (common+wikia) css-file. once i saw @import from wikia on the top of the file, i thought that it was because of moved imports. that's was the mistake: common.css was changed in the middle of my tests, so both common and wikia had same @imports at the top. i did not scroll down the resulting css and did not see imports (from wikia.css) in the middle of the file.

      i noticed the mistake a long time (enough to forget about the topic) after of my msg in the topic.

        Loading editor
    • Ah, okay then. So it was a misunderstanding of what was going on at the time. Thanks for the clarification.

      While I have you here, with regards to Thread:1803028, how do you debug Lua? I have been looking at the errors placed on the page but those aren't always helpful. I did look at the code itself but I just assumed the "[]" was something specific to Lua's syntax for regexs (hence my comment about actually knowing Lua making a difference).

        Loading editor
    • same as any other lang: by tracing execution path up (or down, in this case) to the problem. step-by-step it was:

      1. error message (invalid...) have been returned by "dateerror" function
        1. that means the error was somewhere before the function
      2. there are 9 calls of the fn, so i have to find what exact call produces the error
        1. in order to do this, i would set log(1-9) right before the fn, but in this case i just added param to fn: dateerror(1-9), so fn have returned "invalid... 1"
        2. so problem was somewhere before the "if parts..."
      3. there is only one meaningful line before it: the .split one
      4. there is only two reasons to fail .split: bad date and bad pattern
        1. i have supplied good date, so the problem was with the pattern
      5. quick test in the console (...split('1/1/1',...)...) shows empty values in the resulting table, along with bad table length
        1. the problem definetely in the pattern
      6. i did re-read the docs about ansi and utf patterns and tried another way to write the pattern
        1. it have worked
        2. both ways supposed to work
          1. fandom's text library has bugs
        Loading editor
    • Okay, so no special tool or anything. Just literally making your own copy and modifying the error message to be more helpful. Thanks. Which console are you referring to?

        Loading editor
    • lua console, that shown at the bottom of the page, when you enter edit mode.

      and no, i did not copy the module. you can edit module, then execute module function via console, without saving the module. it's like preview, just slightly more complicated.

        Loading editor
    • Oh. Okay. Thanks for clarifying. As you can probably tell, my experience with Lua is little to none.

        Loading editor
    • A FANDOM user
        Loading editor
Give Kudos to this message
You've given this message Kudos!
See who gave Kudos to this message
Community content is available under CC-BY-SA unless otherwise noted.