FANDOM


  • Recently, I was using Special:MultipleUpload to upload many images at once. However, one image just wouldn't upload - it gave an error message "File extension ".png" does not match the detected MIME type of the file (image/webp)."

    The image was a png image, so I don't know why it wasn't uploading. I deleted the image, downloaded it from the source again, and uploaded it, but it still wouldn't work. I tried this multiple times, but it still didn't work. I then messaged another user asking if he was able to upload it. He successfully uploaded it without any issues.

    Does anyone know what the problem might be? This only happened with one image out of all twenty I was trying to upload.

    Thanks!

      Loading editor
    • most probably your images are not png. they are webp. where did you download those images from? if it was some wiki, then ensure that you downloading the original image, not preview of any kind.

        Loading editor
    • Yep, it was from another wiki. I also make sure to click "see original image," which brought me to the actual image. When downloading the image, it said that it was a png, not a webo.

        Loading editor
    • if it was fandom wiki (image served by vignette), then add &format=original at the end of the original image url and try to save it.

        Loading editor
    • I apologize for the late reply - I did not have the time to do this until just now.

      I did as you said, and it worked. Thank you for the help.

        Loading editor
    • A FANDOM user
        Loading editor
Give Kudos to this message
You've given this message Kudos!
See who gave Kudos to this message
Community content is available under CC-BY-SA unless otherwise noted.