FANDOM


  • Hi Fngplg, it's me again :P, I thought I would message you here rather than on the LinkPreview talk page. Just to let you know, link previews do not appear when hovering over a link in the tabview body. They do appear when hovering over the tabview title though. I've provided an example here.

    After doing a lot of testing of old revisions, I've concluded that revision 72298 was the last time link previews would show in the tabview body. Revision 72299 onwards do not show link previews through tabview properly.

    Just out of interest, is it possible to set an option where the Link previews dont appear when hovering over the tabview title, but will appear when hovering over a link in the tabview body?

    I hope you get a chance to read this at some point. Have a nice day :)

      Loading editor
    • iparents : ['#IgnorePreview', 'div[data-ignore-me=1]']
      

      this line overrides default settings, so u have to add tabview by urself. if u want to exclude tabview header, when content is included, it must be

      iparents : ['#IgnorePreview', 'div[data-ignore-me=1]', '.tabs']
      
        Loading editor
    • Thanks for reply, unfortunately I'm still stuck. I've actually removed all javascript settings to do with LinkPreview, so I'm using unreviewed common.js settings temporarily. The link previews don't appear to be showing in tabview still, despite

      iparents : ['#IgnorePreview', 'div[data-ignore-me=1]']
      

      being removed.

        Loading editor
    • Hi, I made a test page on the ru.borderlands wiki. Link preview doesn't work in tabview mode.

        Loading editor
    • RoIento#3
      I've actually removed all javascript settings to do with LinkPreview

      and preview uses default settings, where tabview is ignored. u still need iparents: ['.tabs'].
        Loading editor
    • Sorry if this is frustrating, I feel like I'm missing something obvious, I'm completely hopeless with javascript so thanks for listening to me so far. This is my current javascript code:

      window.pPreview = $.extend(true, window.pPreview, {
          tlen: 450,
          delay: 30,
          RegExp: {
             iparents: ['#IgnorePreview', 'div[data-ignore-me=1]', '.tabs'],
             onlyinclude : ['.LinkPreviewText', '[data-include-me=1]'],
         },
      });
      

      Using the code above, the link preview shows up when hovering over the tab header, but not on any links in the tab body. I was hoping to achieve the opposite. Have link previews show up on the tab body, just not the tab header.

      Thanks for your patience.

        Loading editor
    • this settings are fine. ensure ur script is working, bypass browser cache.

        Loading editor
    • Fngplg wrote: this settings are fine. ensure ur script is working, bypass browser cache.

      The script works great whenn not using tabview, just the tabview I'm having issues with. I'll bypass the cache more to see if it has any effect, if it doesn't though then no worries :P

        Loading editor
    • there is may be error in the script docking logic, that prevents the script from working on loaded content. i will investigate it soon.

        Loading editor
    • Fngplg wrote: there is may be error in the script docking logic, that prevents the script from working on loaded content. i will investigate it soon.

      No need to rush it :) if you have spare time at some point to fix it that would be great. Thank you :)

        Loading editor
    • Hey Fngplg, thanks for the latest update you did to LinkPreview, previews now show properly in the tabview body :). As for the tabview headers, previews don't show up when using Google Chrome (works good), but I think Firefox may have issues still as link previews often show on tabview titles.

      I'm not saying it's a problem with the script, as I know you've fixed the issue, I think it's a problem on Firefox's end. Just thought I would let you know :)

        Loading editor
    • yeah. it is not a ff problem. it seems like wikia caching issue: some pages just got old version of the script. ?debug=1 helps, but u can't view all pages in the debug mode...

        Loading editor
    • Oh right, I see, thanks for the debug tip! It's not really a big problem though, I can live with it :P.

      It's interesting how the script performs better on Chrome than Firefox though.

        Loading editor
    • A FANDOM user
        Loading editor
Give Kudos to this message
You've given this message Kudos!
See who gave Kudos to this message
Community content is available under CC-BY-SA unless otherwise noted.