Community Central

November has come to an end and the rituals must be observed. Check out This Month at Fandom!


Community Central
Forums: Index Help desk MediaWiki 1.13 upgrade
Fandom's forums are a place for the community to help other members.
To contact staff directly or to report bugs, please use Special:Contact.
Forums: Index Watercooler MediaWiki 1.13 upgrade
Fandom's forums are a place for the community to help other members.
To contact staff directly or to report bugs, please use Special:Contact.
Don't see your message here? It may have been archived to /Resolved issues/

On Wednesday, Septemebr 10th, we upgraded MediaWiki, the software that runs Wikia, to version 1.13.1. You can check out more information about what that upgrade means here. While we don't anticipate any major problems, some issues may appear. Please report any odd site behavior on this page, and we'll try to get those issues resolved as quickly as possible.

Thanks! --KyleH (talk) 17:45, 5 September 2008 (UTC)

Sounds good. I like the double redirect feature.
WHLfan (talk to me!) 22:06, 5 September 2008 (UTC)

The upgrade has been delayed a day in order to ensure a smoother rollout - it is now planned for Wednesday. For those interested, the upgrade will be to 1.13.1, which was released a couple of days ago :) Kirkburn  talk  contr    14:03, 9 September 2008 (UTC)

Summary so far

A quick compilation of user-oriented things and solutions/explanations:

Dark-skin wikis

The following in MediaWiki:Monaco.css will fix the specialpages heading, by making the background darker (change the colour if you want for your wiki):

/* Special:Specialpages fix */ {

There is a delay with updating CSS at the moment, so you may not see the change show up immediately. Kirkburn  talk  contr    13:41, 12 September 2008 (UTC)

Categories with "0" next to them

"It appears that in the category list, the number only displays the number of subcategories rather than the number of articles in the category. So, this behavior is intentional. For example, check out wikipedia:Category:Wikipedia_featured_articles." Kirkburn  talk  contr    13:41, 12 September 2008 (UTC)

The feature itself is intentional; however, "0" is being displayed even for categories which have subcategories (screen shot).    Ryan W 18:57, 14 September 2008 (UTC)
Addendum: hmm, seems to work now.  Many thanks!    Ryan W 18:54, 17 September 2008 (UTC)


For those of you who use User:Kirkburn/global.js or similar, you need to make a small tweak - see here for the change to make. CamelCase ftw! Kirkburn  talk  contr    13:41, 12 September 2008 (UTC)

Problems from being on the old parser

MediaWiki has a new parser/preprocessor which was introduced in 1.12 - it seems some additions in 1.13 rely on it. It's a big improvement on the old parser, but it can require some small template updates so it has not been enabled Wikia-wide yet. There are plans to do so soon, and we'll try and make sure everyone knows what changes. In the meantime, you can view this which gives a rather more technical overview.

Special:ParserDiffTest is enabled on all wikis so that you can test the new parser before asking to have it enabled. If you don't have a compelling reason to ask for the new parser to be enabled, however, we would prefer that you wait until we roll it out Wikia-wide rather than asking for it now. Kirkburn  talk  contr    13:41, 12 September 2008 (UTC)

Special: Categories is empty since Mediawiki 1.13 update

Special:Categories says "The following categories contain pages or media." But the list have no entries. You can select next 20, 50, 100 and all, but allways no category will see. — anonymous 09:29, 10 September 2008 (UTC)

For some reason only categories added since the update seem to show up: wowwiki:Special:Categories. Gourra (talk) 09:58, 10 September 2008 (UTC)

Need we now Null edit all 30,085 articles to have Categories right to see? — anonymous 12:09, 10 September 2008 (UTC)

Maybe for some reason, the software need to rebuild that information, it might take some time... — TulipVorlax 13:49, 10 September 2008 (UTC)
We're aware of this issue and are working to resolve it. --KyleH (talk) 23:32, 11 September 2008 (UTC)
Read →Member counts are wrong, [x] is shown instead of [+] "... populating that table with the current values does not always work when upgraring to 1.13. In that case, run the populateCategory.php maintenance script ..."HenryNe 21:25, 14 September 2008 (UTC)
That script is actually running as we speak, and has been since the upgrade started. The problem is that, with over 9000 wikis, it takes a while to run. I checked yesterday, and we were a little more than half-way through. I anticipate that the categories on all wikis will be properly populated by this weekend. --KyleH (talk) 19:08, 17 September 2008 (UTC)
Ok, I see on w:c:color:Special:Categories, they are up now. Thanks. —HenryNe 19:37, 17 September 2008 (UTC)
The list of categories on this page is back, but the number of articles in each is no longer there. Will that be coming back? -- CocoaZen 04:28, 24 September 2008 (UTC)

Categorytree mode=pages broken

On, the categorytree extension shows no pages (but does show subcategories) with mode=pages and shows them with mode=all. Example: <categorytree mode=pages>Hero icons</categorytree>. DPL works. --◄mendel► 09:50, 15 September 2008 (UTC)

Images aren't considered pages, and it looks to me like that category is all images. (I'm not sure if this behavior is new in 1.13). Try it with <categorytree mode=pages>Subpages</categorytree> instead.
Ah, ok, you're right, and after re-examining the docs I found it is stated there. The working code is <categorytree mode=pages namespaces=Image>Hero icons</categorytree>. Thank you. --◄mendel► 23:45, 18 September 2008 (UTC)

Double Redirects

I think I saw something about it fixing Double Redirects, if so, is there now any point in having the Double Redirects special page? - Kingpin13 on Birds and on Wookieepedia (Talk) 16:26, 10 September 2008 (UTC)

The double redirects are only fixed on page moves - so most cases are covered, but it's still possible to create them otherwise. Kirkburn  talk  contr    16:31, 10 September 2008 (UTC)
Okay, thanks - Kingpin13 on Birds and on Wookieepedia (Talk) 16:35, 10 September 2008 (UTC)
This isn't enabled by default with moves, but the box must be checked to have it done. Is there any way to make this box checked by default and uncheck it when necessary? We'd like to do the same thing for moving the subpages associated with the page.
Peteparker 21:46, 10 September 2008 (UTC)
Currently there is no way to do this (that I can find), but I'll pass the option along as a suggestion. --KyleH (talk) 22:52, 10 September 2008 (UTC)

Weird tab in prefs

There's a wierd tab in preferences titled "# 9" and it dont seems to have any purpose. — TulipVorlax 17:01, 10 September 2008 (UTC)

I assume you're using Internet Explorer? Twas spotted yesterday on Yugioh (which got 1.13 first) - I've updated the report to the techs to say it's now sitewide. Thanks! Kirkburn  talk  contr    17:06, 10 September 2008 (UTC)
Oh yeah, sorry, forgot to talk about specs... I'm on IE7 in Win XP Home. I just checked Firefox, it's not there. — TulipVorlax 22:45, 10 September 2008 (UTC)


Will it mess up the bot if pages like this are categorized (so that other users know not to delete them)?  For that matter, is it okay to delete the pages when upgrade discussions here and on the listserv have died down?  Yes, I searched for documentation of the bot here, and on inside, and on help; I found no explanations.    Ryan W 19:32, 10 September 2008 (UTC)

The bot is editing that page to make sure that your wiki was upgraded successfully (and fix it if it wasn't). It is safe to delete that page at any point, but you may want to wait a few days because it may be recreated as we continue to test to make sure that everything rolled out successfully. --KyleH (talk) 19:46, 10 September 2008 (UTC)
That makes sense.  Thank you.    Ryan W 20:30, 10 September 2008 (UTC)


In the recent changes at Brickipedia it shows somebody moving a page under the upload log. MarioGalaxy2433g5 10+ {talk/contribs/Logs} 21:53, 10 September 2008 (UTC)

As I read above, it seems that all logs are under it. MarioGalaxy2433g5 10+ {talk/contribs/Logs} 21:58, 10 September 2008 (UTC)
I'm not seeing this myself. Can you provide a link to where you're seeing that? And which article you're seeing there? --KyleH (talk) 22:56, 10 September 2008 (UTC)
c:lego:Special:RecentChanges. This is what I see pretty much:
22:05 (Upload log)‎ [MarioGalaxy2433g5‎; TYLERAF‎ (2×)]
22:05 . . TYLERAF (Talk | contribs) (uploaded "Image:Lego AAT Box.JPG")
22:03 . . MarioGalaxy2433g5 (Talk | contribs) (The page Lego roboriders, moved to RoboRiders: Actual name)
22:02 . . TYLERAF (Talk | contribs) (uploaded "Image:Lego Republic Attack Shuttle Box.JPG")
-- MarioGalaxy2433g5 10+ {talk/contribs/Logs} 23:07, 10 September 2008 (UTC)
Ahhh, I see. It appears that in recent changes, all log items are grouped under the most recent log entry. I'll report it. Thanks! --KyleH (talk) 23:13, 10 September 2008 (UTC)


  • Information on the Bureaucrat group is missing.
  • Information on userrights in the staff group is missing.
  • Some groups, such as forumadmin, have very vague information such as "dummyforumadminpermission" (huh?) Dtm142 23:43, 10 September 2008 (UTC)
I've reported these issues. Thanks. --KyleH (talk) 00:00, 11 September 2008 (UTC)
Further, the page should probably have the left cells be vertical-align: top with their CSS. Apparently, Kirkburn was having that view (using who knows what), while I and another on IRC had it as vertically aligned to the center of the row. --Sky (talk) 01:52, 11 September 2008 (UTC)
I still think you're crazy, cause I can't get it to valign middle, either in Firefox or Internet Explorer :P Kirkburn  talk  contr    11:08, 11 September 2008 (UTC)
I just checked the page in Firefox 3, Firefox 2, IE7, and IE6 and the left cells appear valigned to the top on all 4 browsers. On what browser and what wiki are you seeing them valigned to the middle of the cell? --KyleH (talk) 21:08, 11 September 2008 (UTC)
I have seen a similar thing already long before de upgrade; it was in the Wii Opera browser. — TulipVorlax 22:40, 11 September 2008 (UTC)
Ahhh, thanks. I was able to reproduce this issue in the latest version of Opera. I'll pass it along. --KyleH (talk) 23:38, 11 September 2008 (UTC)

The PAGESIZE parser function is absent on some wikis

Meta says the function is new for MW1.13. The usage is {{PAGESIZE:<some page>}}, e.g. {{PAGESIZE:User:KyleH}} or {{PAGESIZE:{{FULLPAGENAME}}}}, and here on central Wikia that works: 13 or 27,814. It works on wowwiki as well, but it doesn't on , ,,, , ... . I haven't tested if any other parser functions are affected. --◄mendel► 10:28, 11 September 2008 (UTC)

It may be related to whether those wikis have the new parser/preprocessor active. It's a big improvement on the normal parser, and was introduced in 1.12, but it can require some small template updates so it has not been enabled Wikia-wide yet. There are plans to do so soon, and we'll try and make sure everyone knows what changes. In the meantime, you can view this which gives a rather more technical overview. Note: if any wikis are desperate to use these things, we are willing to switch you to the new parser early, so long as there is someone knowledgeable who can fix any problems that might arise with templates. Kirkburn  talk  contr    11:20, 11 September 2008 (UTC)
I just tested this and confirmed that the new parser functions only work when the new parser is enabled. If you want the new parser enabled, just let us know, but make sure you understand the implications of doing so. Special:ParserDiffTest is enabled on all wikis so that you can test the new parser before asking to have it enabled. If you don't have a compelling reason to ask for the new parser to be enabled, however, we would prefer that you wait until we roll it out Wikia-wide rather than asking for it now. --KyleH (talk) 21:15, 11 September 2008 (UTC)
On The Comics Databases, we use dpl in a few places to count the number of pages in a category. 1.13 with the new parser has a magic word that does the same thing. Would it be worthwhile to enable the new parser on these wikis to reduce dpl server load? I'm available for template problems pretty much all the time. I looked at some page differences with the Special:ParserDiffTest, but couldn't tell exactly what 'template problems' I was looking for in the output.
Nathan (Peteparker) (Earth-1218) (talkcontribsemail) 19:03, 3 October 2008 (UTC)

Pywikipediabot broken?

Don't know if this is related, but the "Pywikipediabot" is currently broken, erroring out with the following message when trying to get page content: "Got incorrect export page. Sleeping for XX seconds...". Did the behaviour of Special:Export change with the update? -- Cid Highwind 17:01, 13 September 2008 (UTC)

I've been using Pywikipediabot on Wookieepedia before and after the upgrade with no such issues. Are you using a recent SVN and have you edited your family file to reflect the upgrade? -- Darth Culator (Talk) 05:00, 14 September 2008 (UTC)

I've been using both the somewhat old version that still worked before the upgrade, and a recent nightly (2008-09-12). Some of the family changes were missing on my end, but adding those didn't resolve the situation. Will have to investigate further, perhaps it's an issue specific to the Memory Alpha wikis. Thanks for your help, though. :) -- Cid Highwind 14:56, 14 September 2008 (UTC)

  • Checked for running processes. 1 processes currently running, including the current process.
  • Getting references to ...
  • Getting 3 pages from memoryalpha:en...
  • Got incorrect export page. Sleeping for 15 seconds...
  • Got incorrect export page. Sleeping for 30 seconds...
  • Got incorrect export page. Sleeping for 45 seconds...
  • Got incorrect export page. Sleeping for 60 seconds...
Still seems to be happening. To my knowledge, no bots whatsoever are able to work MA. --Alan 21:05, 28 September 2008 (UTC)
I'm looking in to this. I'll let you know when I find out more. --KyleH (talk) 00:16, 30 September 2008 (UTC)
Any word? --Alan 04:12, 17 October 2008 (UTC)
Heya. Sorry for taking so long to respond ... I kind of lost track of this. I was able to get pywikipediabot to work properly on Memory-Alpha. I did have to make one change, however: I had to change the hostname parameter in families/ to (it is distributed by pywikipediabot as "" which fails). eg.
   def hostname(self,code):
        return ''
-- KyleH (talk) 23:36, 20 October 2008 (UTC)

KanzakaDex image problems

I am quite sure this has something to do with the update, as it cropped up just recently. When someone uploads an image, the recent changes show a red link - this did not happen before, and is quite frustrating if someone just wants to view the image in question. Also, there was at least one occasion when the log shows that the image was uploaded, but it is nowhere to be found. (It wasn't deleted, or at least no deletion was recorded in the log.)--Pip25 10:49, 21 September 2008 (UTC)

We'll take a look, thanks for the report. Kirkburn  talk  contr    11:10, 23 September 2008 (UTC)
Thanks. Since then, the situation turned a little worse. This image was available a few hours ago, but now it disappeared without a trace. I actually get a 404 error when trying to view it. --Pip25 16:45, 23 September 2008 (UTC)
Unfortunately what you then saw was an unrelated hardware issue. That's been fixed - still not sure what is happening to your upload though. Kirkburn  talk  contr    13:01, 24 September 2008 (UTC)
I've been able to narrow down the problem a bit. Like I said, the uploaded images show up as red links, as if the "image-article" has not been created. Now if I manually edit the URL, I can see the image, but the "file" tab still shows up red. Also if I delete the image (using the "delete all" link in the image revisions table, as the delete tab is also missing) the image does get deleted, but it will not show up in the deletion log because the system seems to think that the image never existed in the first place. I hope that helps in solving the problem a bit. --Pip25 08:45, 26 September 2008 (UTC)
Can you describe the exact steps to replicate this problem? I can't seem to get it to happen myself. --KyleH (talk) 00:23, 30 September 2008 (UTC)
Upload an image (I just used this JPEG image as a test). You should already see that its link is red. (Strangely, I also got a database error, but the image was still uploaded.) Then, click on the red link from Recent Changes, and change the URL of the upcoming edit page by cutting off the &action=edit&redlink=1 part, which lets you access the image. In the File History, select delete all. (There seems to be no other way to delete it, as the delete tab is missing from the page.) Type in a random reason and delete the file. :) The deletion will NOT show up in the Recent Changes; as you can see I just tried it twice myself, and you can see that the images were uploaded, but there are no sign of them being deleted. I am using the original Monobook skin, and also have Bureaucrat and Sysop privileges in the wiki, if that might be of any importance. --Pip25 07:02, 30 September 2008 (UTC)
I tried uploading a third time, here is the database error I've mentioned:
database query syntax error has occurred. This may indicate a bug in the software. The last attempted database query was:
(SQL query hidden)
from within function "Article::insertOn". MySQL returned error "1062: Duplicate entry '-1-Upload' for key 2 (". --Pip25 07:07, 30 September 2008 (UTC)
I've (re)uploaded it without a problem: My guess is it was MediaWiki glitch caused by the hardware failure Kirkburn was talking about. Please ping us if you find any other image acting weird. -- Nef (talk) 12:29, 9 October 2008 (UTC)
Wait, wait, the above test I described was days after the hardware failure! I see that your upload produces a blue link but if you check out the Recent Changes now you have to notice that it does not work on my side. I am still getting the same database error, the link is still red and test image I just deleted seconds ago was not recorded in the deletion log. --Pip25 12:42, 9 October 2008 (UTC)
Check out RC... My guess no. 2: our upload procedures differ. (-; Could you please describe *very* carefully how did you upload LEAVES.jpg? Either here or on irc or on skype or whatever is easiest for you. Step by step - normal edit page + upload button? Special upload? Some other way? I need to reproduce your steps. -- Nef (talk) 13:01, 9 October 2008 (UTC)
(With OS + browser info, please. -- Nef (talk) 13:02, 9 October 2008 (UTC))
Operating system: Windows Vista Business - Browser: Firefox 3.0.3 - Used skin: Monobook - Bureaucrat and Sysop privileges
I am logged in, looking at the main wiki page. On the bar to the left, I select Upload image/file. I select the LEAVES.JPG file from the disk. (The system notifies me that an image with the same name was already deleted once.) I submit the upload form. I am told that the image already exists on another name (the one you just uploaded). I click "upload anyway". The above SQL error is shown. I click Recent Changes on the left. The image I uploaded is shown in the upload log, but with a red link. --Pip25 14:42, 9 October 2008 (UTC)
Kyle was able to reproduce the problem ...just not every time. )-: Anyway, working on this but not much progress yet. -- Nef (talk) 09:04, 14 October 2008 (UTC)
Thanks. It's certainly odd, though. If you check out the upload log, you admin guys are the only ones who managed to upload pictures with a blue link since a month; all of our editors were unable to do so. Perhaps you should try it from a test account? --Pip25 10:09, 14 October 2008 (UTC)

Possible edit bug

It appears that there is a bug which is disrupting the editing of some articles, over at AvatarWiki, the ones I saw this happen with both had apostrophes in their title. I managed to edit one of them by using a comparison between revisions, but I still have trouble when I try editing the other one. It shows a window with no text, with a headed saying "you're editing a new article". Omnibender - Talk 01:01, 26 September 2008 (UTC)

What is the title of the article that you're having trouble editing? I believe that I have seen this problem myself, but I want to make sure that we're talking about the same thing. --KyleH (talk) 00:24, 30 September 2008 (UTC)

How do we know what Parser version we have ?

I can't use the __HIDDENCAT__ tag to hide categories as well - I went to the Special:Version page on my Wiki Ikaria Wikia Wiki and this is what it showed

Installed software Product Version
MediaWiki 1.13.2
Wikia releases/200810.2 (code r2546, configuration r15312)
PHP 5.2.6 (apache2handler)
MySQL 5.0.50sp1a-enterprise-gpl-log

( Morph | Contribs | Talk ) 23:15, 9 October 2008 (UTC)

The best way to tell if you have the new parser enabled is to try out one of the functions that requires the new parser. For example, {{PAGESIZE:Project:Community Portal}} will return a number if the new parser is enabled (as long as you have a Project:Community Portal page). In your case, the __HIDDENCAT__ function does not work because the parser is not enabled. --KyleH (talk) 23:37, 9 October 2008 (UTC)

Cache related bugs

Please check these bugs:

Eros del Fuego 12:31, 10 October 2008 (UTC)

Line break bug

For some reason, this template stopped working. However, when I remove the "<br>" tag from it, it works again. This is weird because it had worked fine since forever... ― Thailog 12:45, 15 October 2008 (UTC)

This should be fixed by switching on the new parser (described in more detail in #Problems from being on the old parser). It will need checking over before we feel comfortable switching it on Kirkburn  talk  contr    18:31, 15 October 2008 (UTC)
Ok, but is there a way to fix the problem in the meantime? ― Thailog 21:33, 16 October 2008 (UTC)