FANDOM


Forums: Index Community Central Forum How do you install parser functions on wikia?
Fandom's forums are a place for the community to help other members.
To contact staff directly or to report bugs, please use Special:Contact.

50px-Replacement filing cabinet.svg

Note: This topic has been unedited for 3764 days. It is considered archived - the discussion is over. Do not add to unless it really needs a response.


How do you install parser functions on a wiki? I'm trying to use a template I copied from Wikipedia and put it on my own wiki, but it just shows the syntax, and I've been told to install parser functions on my wiki. How do you install parser functions? TurboGolf 18:59, July 6, 2010 (UTC)

You can see the parser functions and extensions installed on your wiki by going to Special:Version. You cannot install extensions or parser functions yourself, you need to ask the Wikia staff at Special:Contact and you must know specifically which ones you need.
Please specify which templates from Wikipedia you are trying to recreate, otherwise it will be very hard to help you. We're not mind readers. -- Fandyllic (talk · contr) 12:03 PM PST 6 Jul 2010

It's Template:Round16. If you can go onto wikipedia and see the edit page, then you'll see what parser functions I need. I dunno what they are. And also, an infobox template I tried to copy from wikipedia aswell but it says "no title" and "no information". TurboGolf 19:29, July 6, 2010 (UTC)

Please provide a link to the template (s) on your wiki as then somebody can then look directly at them, as most wikipedia templates will work on here but often need other templates or adapting to work with existing wikia versions of templates. Most Parser Functions are Generally part of Wikia's std Mediawiki set up since it was upgraded in 2008 (or are you talking about a non Wikia Mediawiki installation ?). I had problems with aload of wikipedia templates befor the upgrade but most work since. (documentation causes most of the problems as it often calls lots of other templates & unraveling what is required and what is not is a problem).
Round16 uses a number of other templates but most of then relate to the documentation & message boxes. The parsers functions look like a load of Ifeq statements that have several varibles passed to them and depending on the value if its true it shows one thing and if its false displays Something else. The message box warning is just a standard message to tell people its a complex (very) template that uses logic functions. 90%+ of the template is drawing the boxes & colouring then in. You need both the template code, as seen in edit mode (- the inter wiki links from the bottom) and the usage syntax seen on the doc page (on the green page in the dotted box). The usage bit is them place in your article and filled in, then when you preiew it you should see the boxes filled in with your data.
PS Wikipedia's infoboxes is NOT directly compatible with wikias basic std Infoboxes code as used on new wikis as they use different variable's. - BulldozerD11 21:43, July 6, 2010 (UTC)
Also note that a lot of Wikipedia's templates are designed for use on wikipedia, and may be overly complex for the puropse they are needed for on many smaller wikis on wikia -- RandomTime 21:50, July 6, 2010 (UTC)
Looking at wikipedia:Template:Round16, there is nothing in it that should require special functions that are not already present on all Wikia. Like BulldozerD11 said, it would help if you linked directly to the template on your wiki. We don't even know if you copied it over correctly. It would also be helpful if you linked to the page you are trying to use it on. Perhaps you're just using the template incorrectly. -- Fandyllic (talk · contr) 9:54 PM PST 6 Jul 2010
Community content is available under CC-BY-SA unless otherwise noted.