FANDOM


This Forum has been archived

Visit the new Forums
Forums: Index Community Central Forum Amperstands in page titles
FANDOM's forums are a place for the community to help other members.
To contact staff directly or to report bugs, please use Special:Contact.

50px-Replacement filing cabinet.svg

Note: This topic has been unedited for 3479 days. It is considered archived - the discussion is over. Do not add to unless it really needs a response.


I'm having a weird problem getting an amperstand to appear normally in a page title in the wikia.css-controlled skin. If you look at w:c:tardis:Northwest Imaging & FX, you'll note it displays as
Northwest Imaging &amp ; FX (extra space between the "p" and ";" added)
but only when reading the article. PAGENAME passes the amperstand properly, and when editing the page, the title at the top of the page appears to again be "Northwest Imaging & FX". We've recently noticed this problem elsewhere on the wiki, as at w:c:tardis:J. Barbour & Sons Ltd. Any thoughts what might be causing this?   17:19, January 23, 2011 (UTC)
It's the Wikia skin - monobook doesn't display this error. Best thing to do would be to contact Fandom Staff -- RandomTime 17:40, January 23, 2011 (UTC)
Bah, that sig screws with RTE.
Anywho, & is special text that's supposed to be rendered as an ampersand in any browser. It's one of a bunch of similar codes - for example,   always renders as a space. I don't know why it isn't rendering properly, but it should be fixable with CSS or JS. So I agree with Randomtime, Special:Contact.  Monchoman45  Talk  Contribs  Skystone  17:47,1/23/2011 
Hi. The developers have fixed this issue, and the fix should go live on Wednesday. :) Cheers, Grunny@fandom (talk) 00:51, January 24, 2011 (UTC)

THe & sign has always had a problem within captions to images as it Truncates the caption,which is a pain as i have several manufacturers with names that use the & within them. The work round is to right it out as "and" which is not correct and also have redirects from the 'long' form. -   BulldozerD11   talk    contribs    email   12:54, January 24, 2011 (UTC)

Characters in Image titles

A related issue is changes to what characters are allowable in File and Image names as last year some that worked in the past stopped working within article but work on uploading so an mage appears to upload and shows a thumbnail but will not appaaer with the article.

Tracking down 'bad' names and moving them (the image) is tricky, as following the broken link dose not work. -   BulldozerD11   talk    contribs    email   12:54, January 24, 2011 (UTC)

Community content is available under CC-BY-SA unless otherwise noted.